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This Index lists all Help topics available for Stable Technical Graphs.    To learn how to use Help, press F1 
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Stable Keys

The following describes the specific keypress sequences available while running Stable Technical 
Graphs.

Key(s) Function

F1 Displays the Help window.

Ctrl+O Selects a new chart.

Ctrl +D Show/Hide the data display.

Ctrl +A Displays the "Attachments" dialog box for the current graph.

Ctrl +P Displays the "Parameters" dialog box for the current graph.

Ctrl +I Displays the "Indicators" dialog box for the current graph.

Ctrl +Z Toggles the zoom mode for the active chart.

Ctrl+Left Arrow Moves the chart's slide to the left.

Ctrl +Right Arrow Moves the chart's slide to the right.

Tab Changes the active graph within a chart.

Shift+Tab Changes the active graph within a chart

Home Scrolls to the first page of security information.

End Scrolls to the last page of security information.

PgUp Scrolls backwards twenty (20) units of security data.

PgDn Scrolls forward twenty (20) units of security data.

Up Arrow Scrolls backwards five (5) units of security data.

Down Arrow Scrolls forward five (5) units of security data.

The following key sequences are used when drawing lines or placing text onto a graph.

Key(s) Function

Shift+Left Button Selects a graph area to zoom.

Ctrl Key Pressed Holding down the Ctrl key while drawing either freehand or speed 
resistance lines will extend the line to the edge of the graph.



File Menu Commands

The File menu includes functions for opening and closing charts, exporting chart data, and printing a 
chart.

Open Chart...

Opens a securities chart using existing financial data in one of the supported file formats.

Close Chart

Closes the active chart, removing it from the current group.

Export Chart Data...

Exports the active charts price data in various ASCII file formats, including the price import format
used by Quicken.

Page Setup...

Allows you to select or set page specific information related to the printing of a chart.

Printer Setup...

Allows you to select and configure the printer that you want to use for printing your securities 
charts.

Print Chart...

Prints the active chart to the printer.

Exit

Exits Stable Technical Graphs.



Group Menu Commands

The Group menu includes functions used specifically for security groups.

New

Create a new group.

Open...

Open a previously saved securities group.

Save

Save the current group.

Save As...

Save the current group as a new group name.

Print All Charts...

Print all charts contained within the group.



Tools Menu Commands

The Tools menu includes functions used for drawing lines and text to a graph.

Normal

Reset the current drawing mode to normal.

Auto Line Extension

Enables or disables the automatic extension of lines drawn on a chart.    If this selection is 
checked, lines are automatically extended to the edge of the graph.

Select

Select an area of the graph to zoom into.

Text...

Draw text onto a chart.

Trend Line

Draw a free-hand trendline on the graph.

Vertical Line

Draw a vertical line at a specific location on a graph.

Horizontal Line

Draw a horizontal line at a specific location on a graph.

Speed Resistance

Draw speed resistance lines between two points on a graph.



Options Menu Commands

The Options menu includes functions for configuring Stable Technical Graphs.

Chart

Allows you to specify various characteristics associated with securities charts; including text 
display, scrolling limits, chart grid lines, and Point & Figure marker size.    Chart Options

File Import

Allows you to specify the number of most recent financial data units used when opening a chart, 
and identifying the default ASCII data formats for files lacking the standard header.    File Import 
Options

Fonts

Use this function to select the style of fonts you want to use for chart labeling, data display, and 
the status bar.    Font Options

Graph

Allows you to select the default colors and number of grids used for new charts.    Graph Options



Graph Menu Commands

The Graph menu includes selections that control the appearance of a graph; including the type of graph, 
parameters specific to the graph, the graph's colors, and if the graph should display its data.

Display Data

Toggles the data display window on or off.

Attachments...

Allows the editing and removal of existing graph attachments.

Parameters...

Allows you to change graph-specific data parameters.

High/Low Bar
Line
Histogram

These menu selections allow you to change the appearance of the current graph.    The 
availability of each option is dependent upon the type of graph (i.e. the High/Low Bar graph is 
only available on the Price Graph).

Zoom In
Zoom Out

Toggle between the display of all chart data, and the display of a fixed amount of data (scrollable).

Indicators...

Allows you to add or remove indicators from a chart.    The availability of specific indicators is 
dependent upon the data content of the security.    For example, if volume information is not 
available for a security, volume-related indicators will not be provided for selection.

List of Technical Indicators



Window Menu Commands

The Window menu provides functions for managing the display of all charts in a group.

Cascade

Displays all charts as cascading windows.

Tile Vertical

Displays all charts as vertically tiled windows.

Tile Horizontal

Displays all charts as horizontally tiled windows.

Arrange Icons

Arranges the display of all minimized charts.

Close All

Closes (removes) all charts from the group.



List of Technical Indicators

The following alphabetic list identifies the technical indicators provided by Stable Technical Graphs.
Commodity Channel Index (CCI)
Moving Average Convergence/Divergence (MACD)
Moving Averages (Exponential, Simple, Weighted)
Multiple Data Graph
Negative Volume Index (NVI)
Negative Volume Trend (NVT)
On-Balance Volume
Open Interest
Point & Figure
Positive Volume Index (PVI)
Positive Volume Trend (PVT)
Price Channel (Trading Band)
Price Momentum
Price Oscillator
Price Performance
Rate of Change (Price and Volume)
Relative Strength
Relative Strength Indicator (RSI)
Stochastic
Volume
Volume Oscillator
Weighted Close

For detailed information on technical indicator theory and practice, we highly recommend that you 
consider the following publications:

Technical Analysis Explained
Martin J. Pring

Technical Analysis of the Futures Markets
John J. Murphy

The New Commodity Trading Systems and Methods
Perry J. Kaufman

The Encyclopedia of Technical Market Indicators
Robert W. Colby & Thomas A. Meyers

Technical Analysis of Stock Trends
Robert D. Edwards & John Magee

New Concepts in Technical Trading Systems
J. Welles Wilder.



Supported Data Formats

The following data import formats are directly supported by Stable Technical Graphs.    For further 
information about these data files, please consult the Stable Reference Manual or Stable User's Guide.

TeleChart 2000 (TC2000)
Comma Separated Value (CSV) ASCII Format
Technical Tools
Commodity Systems, Inc. (CSI)
MetaStock

Comma Separated Value (CSV) ASCII Format

The general format for all ASCII data files that Stable Technical Graphs can interpret is as follows (note 
that the record count record is no longer supported in version 2.0 and above):

Format_String Optional record for version 2.0 and above
Data_Record_1
Data_Record_2
-
-
Data_Record_N

Format_String is a description of the format of each data record in the file.    This string consists of two or 
more of the characters "DVOHLCI" (DC - or Date and Close - is the minimum required for any file), which 
specifies both the sequence and type of data fields in each record:

D represents a Date field

This entry is actually one of the following; 'D' for daily data, 'W' for weekly data, 'Q' for 
quarterly data, 'M' for monthly data, or 'Y' for yearly data.

Additionally, a modifier can follow the date specification character to identify a specific date 
format from the list below:

0 mm/dd/yy    (also the default if '0' is omitted)
1 mmddyy
2 yy/mm/dd
3 yymmdd
4 dd/mm/yy
5 ddmmyy
9 Serialized date format (Lotus-style)

V represents a Volume field (or short interest).

O represents an Open field.

H represents a High field.

L represents a Low field.

C represents a Close field.

I represents an Open Interest field.

Data_Record represents each ASCII record in the file (up to Record_Count entries if included in the file).   
All data records must be of the same field sequence and contain identical types of fields.    Each field in 
the data record is separated form the next using a comma or tab character.

THE FOLLOWING NOTES APPLY TO ALL DATA IMPORTED BY STABLE:

1. Stable Technical Graphs reads and interprets ASCII numeric values in a variety of formats:

Floating point decimal values (i.e., 34.65) for data related to such items as market indexes (i.e., 



DJIA, SP500), mutual funds, and various currency information.

Standard fractional values (i.e., 64 1/8, 20 1/2) for representing data specific to stocks, options, 
and corporate bonds.

Special fractional values (i.e., 76:18) for data representing 1/32ths; such as Government Agency 
Issues (i.e. FNMA, GNMA, World Bank) and Treasury Bonds, Notes and Bills.

2. Numeric values (i.e. volume, open, close, etc.) may not be formatted with a comma (e.g. Use 
12900 instead of 12,900).

3. Holiday data, data that includes zero (0) numeric values for all fields in a particular data record 
volume should not be included in any of your data files.

4. Data is not automatically adjusted for splits or ex-dividends by Stable.

Example ASCII Data

The following are examples of the contents of several different ASCII data files which Stable Technical 
Graphs can read.    In each example, the use of the comma to separate individual fields can be replaced 
by a tab character in your actual data.    In version 2.0 and above, the first record in each example 
(Format String) is optional.

Market Index

DVHLC
1/2/92, 238169, 3184.7, 3119.86, 3172.41
1/3/92, 236228, 3221.38, 3156.31, 3201.48
1/6/92, 272785, 3230.32, 3166.59, 3200.13
1/7/92, 255148, 3224.73, 3165.25, 3204.83
1/8/92, 290369, 3245.53, 3164.58, 3203.94

D9VHLC
33605, 238169, 3184.70, 3119.86, 3172.41
33606, 236228, 3221.38, 3156.31, 3201.48
33609, 272785, 3230.32, 3166.59, 3200.13
33610, 255148, 3224.73, 3165.25, 3204.83
33611, 290369, 3245.53, 3164.58, 3203.94

The above illustrates two examples of files containing 5 data records. Each data record contains five 
fields identified by the "DVHLC" line.    The sequence of the fields is "D"aily Date (the first example is in 
mm/dd/yy format, the second in serial date format), "V"olume, "H"igh, "L"ow, and "C"lose.    Decimal 
values are used.    Note that 'D0' could have also been used to represent this date format.

Mutual Fund

W1C
010389, 14.28
011089, 14.69
011789, 14.67
012489, 14.90
013189, 15.28

The above illustrates a file containing 5 data records. Each data record contains two fields identified by 
the "W1C" line.    The sequence of the fields is "W"eekly Date (in mmddyy form) and "C"lose.    Decimal 
values are used for numerics.

Stock

D3VHLC
900102, 3913, 52 7/8, 52 3/8, 52 3/8
900103, 3628, 53 3/8, 52 1/8, 53 3/8
900104, 5057, 54 1/4, 53 1/4, 53 7/8



900105, 4624, 53 5/8, 53 1/8, 53 3/8
900106, 5203, 53 1/4, 51 5/8, 52 3/4

The above illustrates a file containing 5 data records - each record contains five fields identified by the 
"D3VHLC" line.    The sequence of the fields is "D"aily Date (in yymmdd form), "V"olume, "H"igh, "L"ow, 
and "C"lose.    Volume information is represented as a decimal value, while fractional values are used for 
all others.



DDE Command Summary

The following summarizes the available DDE commands supported by Stable Technical Graphs.    For 
further details about each transaction or command, refer to the Stable Reference Manual or Stable User's
Guide.

Application (Service) Name

For all DDE communication connections established with Stable Technical Graphs, use the name 
"STABLE" as the application or service name.

Topics

Stable supports two classes of topics; the "SYSTEM" topic related to the primary application, and 
ChartName topics associated with the individual chart windows.

Request Transactions

A client can send request (XTYP_REQUEST) transactions to a specific Stable topic in order to receive 
information about that topic.

Topic Item
"SYSTEM" SZDDESYS_ITEM_TOPICS

Returns a list of the available topics; which includes the "SYSTEM" topic, and
the names ChartName of all currently open charts.

SZDDESYS_ITEM_SYSITEMS
Returns a list of supported items for the SYSTEM topic.

SZDDESYS_ITEM_FORMATS
Returns a list of the supported clipboard formats.

SZDDESYS_ITEM_STATUS
Returns the busy or ready status of the server.

ChartName SZDDESYS_ITEM_ITEMLIST
Returns a list of supported items for the chart.

SZDDESYS_ITEM_STATUS
Returns the busy or ready status of the chart.

DATERANGE
Returns the date range associated with the charts data as two dates of the 
format YYMMDD.    As an example, a chart consisting of data for all of 1993 
would return 930104,931231.

"FIELDDEF"
Returns a description of the data content associated with the chart (i.e. 
"DVHLC").

Execute Transactions

A client application can send execute (XTYP_EXECUTE) transactions to a particular Stable topic in order 
to execute a command or series of commands.

Topic Command String
"SYSTEM" "[MINIMIZE]"

Minimize the Stable application window to an icon.
"[MAXIMIZE]"

Maximize the Stable application window to full screen.
"[SHOW]"

Redisplays the Stable window if it was previously an icon.
"[CLOSE]"

Terminates Stable Technical Graphs.
"[CASCADE]"



Redisplay all charts as cascaded windows.
"[TILEVERTICAL]"

Redisplay all charts as vertically tiled windows.
"[TILEHORIZONTAL]"

Redisplay all charts as horizontally tiled windows.
"[OPEN(type,path,file)]"

Opens a new technical chart identified by file in the directory named path of 
data import type type.

ChartName "[SHOW]"
Displays the chart if it was an icon.

"[CLOSE]"
Closes the chart removing it from the desktop.

"[PRINT]"
Prints the chart to the currently selected printer.    The chart must be shown or
maximized before issuing this command.

"[UPDATE]"
Forces the chart to redisplay its contents.

"[MINIMIZE]"
Minimize the chart window to an icon.

"[MAXIMIZE]"
Maximize the chart window.

"[EXPORT(file,symbol,format,startdate,enddate,header)]"
Exports the price data of the chart to an ASCII file.

Poke Transactions

A client application can send unsolicited data to a Stable chart through use of the DDE poke 
(XTYP_POKE) transaction.    This is the method by which new or real-time data can be submitted to a 
Stable chart for display and update.

Topic Item Data
ChartName "NEWDATA" "ASCII Data Record"

ASCII Data Record represents an individual day of data formatted to the chart's reported "FIELDDEF"
format.    Assuming a reported field definition of "DVHLC", the following would be an example of a 
valid record:

12/20/91, 180906, 34 1/2, 32 1/8, 33



Application Toolbar

The Stable Technical Graphs toolbar provides an efficient mechanism for performing those operations 
and functions performed most frequently.

Open Chart

Opens a securities chart using existing financial data in one of the supported file formats.

New Group

Create a new group.

Open Group

Open a previously saved securities group.

Save Group

Save the current group.

Print Chart

Prints the active chart to the printer.

Normal

Reset the current drawing mode to normal.

Text

Draw text onto a chart.

Select

Select an area of the graph to zoom into.

Trend Line

Draw a free-hand trendline on the graph.

Vertical Line

Draw a vertical line at a specific location on a graph.

Horizontal Line

Draw a horizontal line at a specific location on a graph.

Line Color

Select the color to be used for all subsequent line drawing.



Line Style

Select the style to be used for all subsequent line drawing.

Cascade

Displays all charts as cascading windows.

Tile Vertical

Displays all charts as vertically tiled windows.

Tile Horizontal

Displays all charts as horizontally tiled windows.

Previous Chart

Make the previous chart the active chart.

Next Chart

Make the next chart the active chart.



Limited Warranty

ALL WARRANTIES (INCLUDING ANY WARRANTY OF MERCHANTABILITY OR FITNESS FOR ANY 
PARTICULAR PURPOSE) ARE EXPRESSLY EXCLUDED.    THIS SOFTWARE AND ALL PROGRAM 
FILES ARE PROVIDED "AS IS" AND THE USER MUST ASSUME THE ENTIRE RISK OF USING THIS 
PROGRAM.

TRIAL USE (SHAREWARE EVALUATION VERSION) WARRANTY

The Shareware evaluation (trial use) version of Stable Technical Graphs is provided "AS IS".    
WINTERRA(TM) Software Group makes no warranties of any kind, expressed or implied, that this 
program is error free or that any supplied data or other program information is accurate or complete.    No 
representation or warranties are made as to the completeness, accuracy, or precision of this program.

LICENSED VERSION

WINTERRA(TM) Software Group warrants the physical diskette(s) and physical documentation provided 
with SOFTWARE to be free of defects in materials and workmanship for a period of 90 days from the date
of purchase.    If WINTERRA Software Group receives notification within the warranty period of defects in 
materials or workmanship, and such notification is determined by WINTERRA Software Group to be 
correct, WINTERRA Software Group will replace the defective diskette(s) or documentation.

The entire and exclusive liability and remedy for breach of this Limited Warranty shall be limited to the 
replacement of defective diskette(s) or documentation and shall not include or extend to any claim for or 
right to recover any other damages, including but not limited to, loss of profits or other trading losses 
incurred as a result of any decision or action taken on your part based upon information provided, implied,
or suggested by the SOFTWARE, loss of data, loss of use of the SOFTWARE, or any other special, 
incidental, or consequential damages or other similar claims, even if WINTERRA Software Group has 
been specifically advised of the possibility of such damages.    In no event will WINTERRA Software 
Group's liability for any damages to you or any other person ever exceed the lower of the suggested list 
price or actual price paid for the license to use the software, regardless of any form of the claim.    Some 
states do not allow limitations on the duration of the implied warranty, so the above limitation may not 
apply to you.



Licensed Version Registration Form

To become a licensed user of Stable Technical Graphs, please print and return this registration form along
with your check or postal money order (drawn on U.S. funds only), or credit card information and mail to:

WINTERRA Software Group
P.O. Box    4106

Highlands Ranch, CO        80126
Voice/Fax: (303) 470-6323

Upon registration, you will receive the latest version of Stable Technical Graphs, a laser-printed User's
Manual, future upgrade notifications, and free technical product support.

Name: _______________________________________________________

Company: _______________________________________________________

Address: _______________________________________________________

City: _________________________ State: _____    Zip:    ____________

Phone: (______)_______________ Fax: (______)_______________

Date: __________________ CompuServe ID: __________________

Disk Format: ____ 3 1/2"
____ 5 1/4"

Quantity: ____ Stable Technical Graphs @$49.95 $____________

Shipping/Handling
____ U.S. @$    4.00 $____________
____ Canada/Mexico @$    6.00 $____________
____ International @$12.00 $____________

        TOTAL $____________

Method of Payment: [___] Check [___] Credit Card

Credit Card Information: [___] Visa [___] Mastercard

Card Number: ___________________________________

Name on Card: ___________________________________

Expiration Date: ___________________________________

Signature: ___________________________________



Shareware Information

Stable Technical Graphs is not free software!

WINTERRA Software Group grants a limited license for you to evaluate this financial application 
for a period of 30 days in your own environment.    This "try before you buy" method lets you 
determine if the product meets your individual needs without having to actually purchase it first.    
However, if you continue to use the product after the 30 day evaluation period, you are required to 
purchase a licensed version of Stable Technical Graphs and become a registered user.

If you feel the product does not meet your needs after the evaluation period, you must discontinue further 
use of the product and remove it from your computer system.

Once you register and purchase a licensed version of Stable Technical Graphs, you will:

o Receive the latest version of the application.

o Receive a comprehensive User's Manual for the product.

o Receive all minor updates and application fixes as they become available - including any 
new technical indicators that may be added to the product.

o Receive advance notification of all new major product releases.    As a licensed user you 
will be offered major version releases at a substantially reduced and favorable rate.

o Receive free technical support by phone, fax, mail, and E-mail via CompuServe.

o Be eligible to participate in any "beta testing" programs associated with future releases of 
Stable Technical Graphs.

Product Description and Features

Licensed Version Order Form



Product Description

Licensed Version Order Form

Stable Technical Graphs v2.0 is a financial technical analysis application for Microsoft Windows 3.1 and 
above, and contains many of your most requested features.    Written for experienced and novice users 
alike, Stable provides powerful - yet easy to use - stock market technical analysis capabilities ideal for the
technical trader with existing (or access to) historical financial data for stocks, bonds, commodities, 
mutual funds, indexes, and options.

Combining popular technical indicators with features such as DDE (Dynamic Data Exchange), chart 
printing, selectable graph styles, new data import/export formats, popup graph menus, enhanced desktop 
management features, and more - Stable Technical Graphs is likely to become an indispensible tool in 
your Windows financial tools arsenal.

Stable Technical Graphs reads TeleChart 2000 (TC2000), CSI, Technical Tools, MetaStock, and ASCII 
formatted data files; allowing you to use your existing data more effectively.    All Stable charts support 
selectable zoom and horizontal scrolling - giving you the ability to study as many as 16,384 units (days, 
weeks, etc.) of data in a single graph. And when you identify a chart worthy of more attention, simply print 
it to your system printer.

All Stable Technical Graphs charts provide an easy to use "slider" for accurately comparing a specific 
day's activity across several graphs.    Also available is an application "toolbar" providing single mouse 
click operation of frequently used charting operations and tools.

Other standard features found in Stable Technical Graphs include the following:

o Financial groups can be created for organizing and collecting any number of individual 
charts into a common group

o Multi-data charts can be created for analyzing several underlying securities in the same 
chart.

o Interactive chart drawing tools; including trend lines, speed resistance lines, and text 
attachments can be drawn and saved with any chart.

o All charts are scalable along the X and Y axis - and include chart zoom and selectable 
area functionality.    As many as 16,384 days of data are supported for each and every 
chart.

o New indicators have been added including Point & Figure, Stochastic, and Performance 
graphs.

o Chart data can be exported to various ASCII file formats; including the price history 
format used to import into Quicken(TM).

o Improved desktop chart management has been provided using the standard Microsoft 
Windows Multiple Document Interface (MDI).

o Up to 8 technical analysis indicators can be created on each chart.

o Dynamic Data Exchange (DDE) support has been built in - allowing you to communicate 
directly with any Stable chart through the use of third-party software (such as Microsoft 
Excel) to open, print, display - or to dynamically add new data to a chart.

o "Drag and Drop" support is available - allowing CSV and Technical Tools data files to be 
opened simply by "dragging" a file from the File Manager directly to the Stable application
window or icon.

o User-selectable graph styles; including High/Low Bar, Line, and Histogram graphs.

o Popup menu support within any graph allowing you to quickly perform many common 
graph functions.



o On-line help documentation using the standard Window's Help program.

o All chart and graph colors are easily selected and changed to suit your own personal 
preference.



Adding and Removing Technical Indicators

You can have as many as eight (8) technical indicators on each chart for analyzing and studying the 
underlying financial data.

To add or remove technical indicators:

1. Select the graph by clicking within the graph, or by "tabbing" to the graph.

2. Select Indicators... from the Graph Menu.

-OR-

Click on the Ind button at the lower right corner of the chart.

3. In the Technical Indicators dialog, add indicators from the list on the left - or remove 
indicators from the list on the right.

4. Click the OK button to accept your changes.

List of Technical Indicators



Adding New Attachments

Attachments are graphical elements such as lines and text which you place on a graph.    To add an 
attachment, perform the following procedures.

To add an attachment:

1. Select the attachment you want to add from the Tools menu.

-OR-

Click the desired attachment button on the toolbar.

2. Move the mouse to the location on the graph where you want to place the attachment. 
The mouse cursor appearance changes to the selected attachment type.

Once the above steps have been performed, various actions occur depending on your selected 
attachment type:

Text attachment:

3. Click the left mouse button to drop the attachment onto the graph.

4. Enter the text and select the colors, alignment, and other styles from the available options
- then press the OK button.

Trend line attachment:

3. Click and hold the left mouse button to anchor the first endpoint, then move the mouse to 
the location where you want the second endpoint to be.

4. Release the left mouse button to complete the trend line.

Tip: Holding the Ctrl key down during the above procedure will extend the line beyond 
the second endpoint to the edge of the graph.

Vertical and horizontal line attachment:

3. Click the left mouse button to draw the vertical or horizontal line.    The line is drawn to the
edges of the graph.

Speed resistance line attachment:

3. Click and hold the left mouse button to anchor the first endpoint, then move the mouse to 
the location where you want the second endpoint to be.

4. Release the left mouse button to complete the speed resistance line.    Two lines 
originating from the earlier endpoint are drawn, each representing the 1/3 and 2/3 speed 
resistance points.

Tip: Holding the Ctrl key down during the above procedure will extend the lines beyond 
the second endpoint to the edge of the graph.

Additional Notes:

o Trend and speed resistance line extension can be performed either by holding the Ctrl 
key down while drawing the line, or by selecting Auto Line Extension from the Tool menu 
before selecting the attachment type.

o The color and style of all lines can be selected prior to drawing from the color and style 
combo boxes found in the programs toolbar.

Displaying Graph Data



Adjusting Chart and Graph Sizes

As more charts are added to a financial group, you may want to change the size of the charts to 
accommodate the optimal viewing of each chart.    When new technical indicator graphs are placed within 
a chart, the size of the price graph changes to make room for these additional graphs.

To adjust the size and location of charts:

Charts are effectively standard windows that support the normal window management techniques
found in the Microsoft Windows environment.

You can resize any chart window by clicking on the border of the window and dragging the sizing 
rectangle until the desired size is set.    You can reposition a window by clicking on the windows 
title and dragging the window to a new location.

Additionally, you can perform standard tiling and cascading of financial chart windows by 
choosing the appropriate selection from the Window menu.

To interactively change the size of the Price Graph (only when one or more technical indicators 
are visible):

1. Move the mouse to the location between the Price Graph and the first technical indicator 
graph until the mouse cursor changes to a double vertical arrow.

2. Press and hold down the left mouse button.

3. Move the mouse vertically to set the new bottom of the Price Graph.    As you move the 
mouse, a horizontal line is drawn to identify the new bottom of the Price Graph.

4. Release the mouse to set the new Price Graph size.



Automatic Price Graph Labeling

Stable provides the option of automatically labeling your Price graphs.    When this option is selected, 
Stable determines the available space on the Price graph and automatically generates horizontal grids 
and labels that optimally fit within this space.

To select automatic labeling for your Stable charts:

1. Select Chart... from the Options menu.

2. Check the box labeled "Automatic Price Graph Labeling".

To use normal text labeling on your Stable charts:

1. Select Chart... from the Options menu.

2. Clear the box labeled "Automatic Price Graph Labeling".



Changing a Graph's Drawing Style

The drawing style for a graph can be changed so that you can interpret the data more easily.    Stable 
supports three basic drawing styles; a High/Low Bar graph, a Line graph, and a Histogram.    The 
High/Low Bar style is available only for the Price graph.

To change the drawing style for a graph:

1. Select the graph by clicking within the graph, or by "tabbing" to the graph.

2. Select High/Low Bar, Line, or Histogram from the Graph menu on the chart.

-OR-

Activate the popup graph menu and select High/Low Bar, Line, or Histogram from the 
menu.



Changing Graph Colors (and Horizontal Grids)

You can change the colors (and the number of horizontal grids) for any graph displayed in a chart.

To change a graph's colors:

1. Select the graph by clicking within the graph, or by "tabbing" to the graph.

2. Choose Parameters... from the Graph menu.

-OR-

Activate the popup graph menu and select Parameters... from the menu.

Selecting the Number of Horizontal Grids



Changing and Removing Attachments

Attachments are graphical elements such as lines and text which you place on a graph.    To remove or 
make changes to an attachment, perform the following steps.

To access the list of all attachments on a graph:

1. Select Attachments... from the Graph menu.

-OR-

Click the right mouse button on the graph and select Attachments... from the popup 
menu.

2. Choose Delete or Edit... to remove or change the attachment.

To change the location of an attachment:

1. Click and hold the left mouse button over the attachment and drag it to the new location.

To delete an attachment:

Option 1

1. Select Attachments... from the Graph menu.

-OR-

Click the right mouse button on the graph and select Attachments... from the popup 
menu.

2. Select the attachment from the list and choose the Delete button.

Option 2

1. Double-click on the attachment in the graph.

2. Choose Delete from the displayed dialog to remove the attachment.

To change the color or style of an attachment:

Option 1

1. Select Attachments... from the Graph menu.

-OR-

Click the right mouse button on the graph and select Attachments... from the popup 
menu.

2. Select the attachment from the list and choose the Edit... button.

Option 2

1. Double-click on the attachment in the graph.

2. Make changes to the information in the displayed dialog and choose the Ok button.

Displaying Graph Data



Displaying Graph Data

For any graph displayed in a chart, you can choose to have the graph display the underlying data on 
which it is based.    One "day" of data is displayed based on the current position of the slide.

To display the data associated with a graph:

1. Select the graph by clicking within the graph, or by "tabbing" to the graph.

2. Select Display Data from the Graph Menu on the chart.

-OR-

Press CTRL+D on the keyboard.

-OR-

Activate the popup graph menu and select Data Display from the menu.

Using the Slide



Displaying Moving Averages on a Graph

As many as three (3) individual moving averages can be displayed on a price or indicator graph.    In 
addition to specifying the number of units for these averages, the type of average (Simple, Weighted, or 
Exponential), any shift factors, and its color can be indicated.

To select and specify a moving average:

1. Select the graph by clicking within the graph, or by "tabbing" to the graph.

2. Select Parameters... from the Graph Menu on the chart.

-OR-

Press CTRL+P on the keyboard.

-OR-

Activate the popup graph menu and select Parameters... from the menu.

To remove a moving average:

* Set the number of units to zero (0) for the specific average.

Displaying a Price Channel



Displaying a Price Channel

A price channel can be displayed on a graph along with moving averages.    In addition to specifying the 
number of units for the channel, the type of average (Simple, Weighted, or Exponential), the shift factors, 
and its color can be specified.

To select and specify a price channel:

1. Select the graph by clicking within the graph, or by "tabbing" to the graph.

2. Select Parameters... from the Graph menu on the chart.

-OR-

Press CTRL+P on the keyboard.

-OR-

Activate the popup graph menu and select Parameters... from the menu.

To remove the price channel:

* Set the number of units to zero (0) for the price channel.

Displaying Moving Averages on the Price Graph



Drag and Drop

Stable charts can be opened using "Drag and Drop".    By simply selecting a file from the File Manager, 
and "dragging" that file using the mouse into the Stable window or icon, you can easily create new charts 
without the need to interact with the Open Chart dialog.

Stable supports "Drag and Drop" using two types of historical data files; CSV and Technical Tools data 
files.    Any other data file format is ignored by Stable.

Refer to your Windows 3.1 documentation for more information on the Drag and Drop facility of Windows 
3.1.



Dynamic Data Exchange    (DDE)

Stable Technical Graphs functions as a DDE server application; responding to client applications by 
providing technical graph services in the areas of chart display management and real-time data update.

In the area of display management, Stable Technical Graphs provides basic control over the creation and 
display of technical charts:

o Charts can be opened or created by a DDE client application through the use of execute 
transactions issued to Stable as the "SYSTEM" topic.

o The Stable window can be controlled using DDE execute transactions.    Supported 
commands allow the window to be minimized, shown (normal), and closed.

o Individual charts can be controlled visually through DDE execute transactions.    Among 
the supported command actions are minimize, maximize, print, show, close, update, and 
export.

Real-time data update of Stable charts is also supported.    By passing ASCII data record information 
conforming to the underlying security's content, new financial data can be submitted to a Stable chart for 
immediate update and display.

For further details about DDE functionality provided by Stable, refer to the Stable Reference Guide, 
Stable User's Guide, or DDE Command Summary.



Exporting Chart Data To An ASCII Data File

Once a chart has been opened, the underlying financial data (i.e., volume, close, etc.) used to draw the 
chart can be saved as an ASCII data file.    This allows you to share the data with other third-party 
products such as Quicken(tm), various spreadsheet programs, and even other technical analysis 
applications.    This feature also provides a way of converting financial data in one format (i.e., TeleChart 
2000, MetaStock, CSI, etc.) to an ASCII file.

Supported Data Formats

To export the active charts financial data:

1. Choose Export Chart Data from the File Menu.

2. Specify the name of an output ASCII data file.

3. Select other export options from the dialog.

4. Select Export New or Export Append to write the ASCII data.

To export the charts price data to a file that can be imported into Quicken:

1. Enter a file name in the File Name box (or choose Browse to search for an existing file).

2. Select Quicken Historical as the export format.

3. Enter the symbol id (i.e., IBM, HRB, etc.) matching the id used in your Quicken database.

4. Select a data export range.

5. Choose Export New to create a new file, or Export Append to add the data to the end of 
an existing ASCII file.

To export the charts price data to an ASCII file that can be used by Stable:

1. Enter a file name in the File Name box (or choose Browse to search for an existing file).

2. Select CSV (ASCII) as the export format.

3. Verify or change the data format to match your new files requirements.    If you are 
creating a file to be used by Stable Technical Graphs, you should accept the displayed 
default (Supported Data Formats).

4. Check the box for Include Format Header.

5. Select a data export range.

6. Choose Export New to create a new file.



Printing Charts

You can print individual or every financial chart in a group from Stable Technical Graphs.    All printing is 
performed in a "fit to page" mode - where the chart is printed to fill the entire printed page within your 
specified margins.

To print an individual financial chart:

1. Choose Print... from the File menu.

-OR-

Click on the Print button in the toolbar.

To print all charts in a financial group:

1. Select Print All Charts... from the File menu.

Changing Printers and Print Options



Scrolling Through a Graph

In some instances you will find that the securities data you are displaying extends beyond the left and/or 
right borders of your graph.    You can gain access to all of the data using the scroll bar displayed at the 
bottom of the chart window, or by using the navigation keys supported by Stable Technical Graphs.

To scroll forward through your graph data:

* Click the right arrow on the scroll bar, or press the Down Arrow key, to move forwards 
your selected arrow distance.

* Click the page right area of the scroll bar, or press the PgDn key, to move forward by 
your selected page distance.

* Press the End key to move to the last page of data.

To scroll backwards through your graph data:

* Click the left arrow on the scroll bar, or press the Up Arrow key,    to move backwards 
your selected arrow distance.

* Click the page left area of the scroll bar, or press the PgDn key, to move backwards your 
selected page distance.

* Press the Home key to display the first page of data.

To scroll to any location within your graph data:

* Drag the scroll bar's thumb horizontally along the scroll bar and position the date text for 
the desired time range, then release the mouse.

sStable Keys



Selecting a Graph

You can select a graph as the active graph in a chart for the purpose of changing its display 
characteristics; including the display of its underlying data, the type of chart, its colors, and any other 
indicator-specific parameters.

To select a graph within a chart:

1. Click anywhere within the graph's border; including its display area and label.

-OR-

Press Tab or SHIFT+Tab to sequence through all the graphs in a chart.



Selecting a Printer and Options

You can select any attached printer to print your securities charts and also select options specific to the 
printer.

To change printers and/or specify printer options:

1. Choose Printer Setup... from the File menu.

2. Select the printer you want to use for printing.

3. Choose Options... to change the printers options.

4. Select OK to save the new settings.

Printing a Chart



Setting the Number of Horizontal Grids

You can specify the number of horizontal grids displayed on a graph.    For every displayed grid line, a 
corresponding value is shown in the label area of the graph.    If Automatic Price Graph Labeling has been
selected in Chart Options, the number of horizontal grids will automatically be determined and this value 
ignored.

To change the default number of horizontal grids for all new charts:

1. Choose Default Graph Colors from the Configure Menu on the Logo window to set the 
default number of horizontal grids displayed on all new Price and Indicator Graphs.

To change the number of horizontal grids for a displayed graph:

1. Select the graph by clicking within the graph, or by "tabbing" to the graph.

2. Choose Parameters... from the Graph Menu.

-OR-

Press CTRL+P on the keyboard.

-OR-

Activate the popup graph menu and select Parameters... from the menu.

Changing Graph Colors



Popup Graph Menu

Stable provides a method by which you can even more effectively use your technical charts.    This 
method allows you to access some of the more frequently used graph functions while you concentrate 
your attention directly on the graph.

To take advantage of the popup menu support:

1. Move the mouse within any visible graph and click and hold the right mouse button.

2. Make a selection from the popup menu by selecting an item, then releasing the right 
button.



The Slide

The slide (which is positioned at the top of each chart) is used for focusing on a particular day on a chart.  
"Attached" to the slide is a vertical line or hair that provides a mechanism for precise vertical alignment 
across all graphs displayed on the chart.    As you move the slide horizontally, the hair will follow and all 
data display areas will be updated with the actual graph data for that day.

To move the slide horizontally:

1. Press CTRL+Left Arrow or CTRL+Right Arrow on the keyboard.

-OR-

Press and hold down the mouse button over the slide, and move the mouse horizontally 
from side to side.

Displaying Graph Data



Opening Financial Charts

Financial charts are created from existing financial data.    Stable Technical Graphs does not provide 
functionality for creating financial data files.

To create or open a new chart:

1. Select Open Chart... from the File menu.

-OR-

Click on the Open Chart button in the toolbar.

2. Choose one of the supported Import File Types and navigate through your system 
directories to the directory containing the financial data for your selected type.

3. Select the security name or data file from the File Name list box and click the OK button.

-OR-

Double-click on the security name or data file listed in the File Name list box.

Displaying Graph Data



Formatting the Printed Page

You can specify the margins used for printing a financial chart as well as a standard title you want to print 
on each chart.

To specify a chart title and page margins:

1. Select Page Setup... from the File menu.

2. Enter the report heading you want printed on each financial chart (Optional).

3. Enter the top, bottom, left, and right margin values in inches for the chart.

4. Click OK to save your new settings.



Financial Chart Groups

Stable Technical Graphs provides a feature for organizing and collecting a number of individual charts into
a common group.    These financial groups can contain almost any collection of one or more securities 
meeting your specific analysis needs.

For example, a group might contain a collection of market indexes.    Another group might contain all the 
securities in your portfolio, while another might include mutual funds of a particular sector group.    The 
choice of securities is totally up to you.

To create a new financial group:

1. Select New from the Group menu

-OR-

Click on the New Group button in the toolbar.

2. Add new charts to your group by opening each chart using the Open Chart... selection on
the File menu or clicking the Open Chart button on the toolbar.

3. Organize the charts in the group by adjusting the sizes and positions of each chart.    
Include any technical indicators with each chart.    List of Technical Indicators

4. Save your new group by selecting Save or Save As... from the Group menu (or by 
clicking the Save button on the toolbar).

5. Enter a descriptive name for your new group and choose the OK button to save the 
information.

To open an existing financial group:

1. Select Open from the Group menu

-OR-

Click on the Open Group button in the toolbar.

2. Select an existing group to open by choosing a name from the Group List and clicking the
OK button.

-OR-

Double-click on the name of the group in the Group List box.

To delete an existing financial group:

1. Select Open from the Group menu

-OR-

Click on the Open Group button in the toolbar.

2. Select an existing group to open by choosing a name from the Group List.

3. Click the Delete button to remove the group.

To change which charts are in the financial group:

1. Simply open or delete existing charts from the display, and then save the group by 
selecting Save or Save As... from the Group menu - or click the Save Group button on the
toolbar.



Chart Options

Many of the operational characteristics associated with Stable charts can be configured to meet your own 
needs and preferences.

To modify any of the available chart options:

1. Select Chart... from the Options menu.

2. Modify or choose from the various configuration options.

3. Choose OK to save the new settings.

Chart Option Settings and Their Use:

3-D Text and Raised Text
These options allow you to configure the appearance of text used in labeling your charts.    Select 
3-D text to use three-dimensional text labels.    Raised or recessed text is controlled uusing the 
Raised Text checkbox.

Automatic Price Graph Labeling
Select this option if you want Stable to automatically determine the price values and number of 
horizontal grids for your price graphs.    If this option is not selected, you can select the number of 
horizontal grids individually for each price graph (Selecting the Number of Horizontal Grids).

Vertical Scroll Bars
This option adds vertical scroll bars to every graph.    Normal use of Stable will not require these.

Color Printing
Select this option only if you have a color printer and want to print graph lines in color.    The 
background color for all printed graphs is white.    If you fail to get satisfactory results using this 
option - or if you have a black and white printer - turn this option off.

Chart Scrolling
You can specify the number of data units you want your charts to scroll by setting these values.    
The Arrow Distance is the amount to scroll when the scroll bar arrow is clicked.    The Page 
Distance is the amount to scroll when the page area of the scroll bar is clicked.

Chart Grids
Select the usage of, and line style, for both the vertical and horizontal grids displayed in every 
graph.

Point & Figure Graph - Maximum Marker Width
Assign the maximum width (in pixels) of the X and O markers used in Point & Figure graphs.    
This value is the largest display size you will accept for use within the graph.





File Import Options

Stable Technical Graphs allows you to specify the number of most recent data units you want graphed in 
each of your charts, as well as providing a mechanism for importing ASCII files that do not conform to the 
normal Stable ASCII file specification.

Selecting the number of recent data units used in your charts:

The amount of data loaded into Windows memory for all charts is configurable to meet your own personal
analysis needs, or to address any specific memory constraints or problems you might encounter when 
running the Stable Technical Analysis program.

When Stable Technical Graphs opens a chart, it loads the most recent data up to a selected number of 
units.    The number of units is specified by you and can range from 2 up to 16,384.

To specify the number of graph units:

1. Select File Import... from the Options menu.

2. Indicate the maximum number of data units you want each graph to contain by entering a
value from 2 to 16,384 in the edit box labeled Most Recent Data Units.

3. Choose OK to save your selection.    Any chart opened after this change is made will 
contain a maximum of the number you specified.

Support for Non-Standard ASCII File Formats:

Stable Technical Graphs supports the reading of some ASCII data files that do not conform to its normal 
format - such as those used by other third-party analysis programs or some spreadsheet applications.    
Normally, these ASCII files do not contain the Data Format record specified by Stable as the first record in
an ASCII file (Supported Data Formats).

Through File Import Options, you can specify default ASCII file formats which Stable will assume when it 
encounters a file which does not contain the normal data format record.

To specify default file formats:

1. Select File Import... from the Options menu.

2. Enter the default file format definitions you want Stable to assume for ASCII files 
containing 2, 3, 4, 5, 6, and 7 fields.

3. Choose OK to save your selections.





Font Options

You can select the font styles used by Stable Technical Graphs for chart labels, data display, and the 
status bar located at the bottom of the program window.    This feature allows you to optimize your charts 
appearance based on the resolution of your display.

To select a font style:

1. Select Font... from the Options menu.

2. The currently selected font styles are displayed for each appearance selection type.    
Choose the appearance type to change by clicking on its descriptive button.

3. Select the font style from the Font dialog and choose the OK button to accept the new 
setting.

4. Choose the OK button of the Font Options dialog to redisplay using your new font 
choices.



Graph Color Options

You can select the default colors (and the number of manual horizontal grids) used when a chart is 
opened by selecting Graph... from the Options menu.

To select the default graph colors:

1. Select Price... or Indicators... from the Graph selection on the Options menu.

2. Select the background, foreground, and grid colors.    If you are not using the automatic 
labeling feature, enter the number of horizontal grids you want for your default graphs.

Tip: The automatic chart labeling feature should normally be used.

3. Choose the OK button to save your selected settings.

Selecting the Number of Horizontal Grids






